Bonjour à tous, j'ai un travail à faire sur AlgoBox pour lundi : "Ecrire un algorithme permettant d'affirmer si un quadrilatère ABCD est un parallélogramme connaissant les coordonnées des sommets " "Ecrire un algorithme permettant d'affirmer si trois point H,I et J sont alignés connaissant leurs coordonnées" Si quelqu'un sait comment utiliser ce logiciel et faire ces algorithime c'est avec plaisir que je prend son aide.... :)

1

Réponses

Meilleure réponse !
  • Utilisateur Brainly
2013-04-16T22:47:04+02:00

 

algo - 16.04.2013

 

 

 

1 VARIABLES

2 xA EST_DU_TYPE NOMBRE

3 yA EST_DU_TYPE NOMBRE

4 xB EST_DU_TYPE NOMBRE

5 yB EST_DU_TYPE NOMBRE

6 xC EST_DU_TYPE NOMBRE

7 yC EST_DU_TYPE NOMBRE

8 xD EST_DU_TYPE NOMBRE

9 yD EST_DU_TYPE NOMBRE

10 x_AB EST_DU_TYPE NOMBRE

11 y_AB EST_DU_TYPE NOMBRE

12 x_DC EST_DU_TYPE NOMBRE

13 y_DC EST_DU_TYPE NOMBRE

14 u EST_DU_TYPE NOMBRE

15 v EST_DU_TYPE NOMBRE

16 DEBUT_ALGORITHME

17 x_AB PREND_LA_VALEUR xB-xA

18 y_AB PREND_LA_VALEUR yB-yA

19 x_DC PREND_LA_VALEUR xC-xD

20 y_DC PREND_LA_VALEUR yC-yD

21 u PREND_LA_VALEUR x_AB-x_DC

22 v PREND_LA_VALEUR y_AB-y_DC

23 SI ((u=0) et (v=0)) ALORS

24 DEBUT_SI

25 AFFICHER "ABCD parallélogramme"

26 FIN_SI

27 SINON

28 DEBUT_SINON

29 AFFICHER "ABCD quadrilatère"

30 FIN_SINON

31 FIN_ALGORITHME