Bonjour j'ai besoin d'aide,

Voila l'exercice:

Entrées
Saisir n : entier naturel superieur à 2
Saisir une liste de reels : X1, X2,....Xn

Traitement
Pour i de 1 jusqu'a n-1
j prend la valeur de n
Tant que i<j
Si Xj<Xj-1 alors
Echanger Xj et Xj-1 dans la liste
FinSi
j prend la valeur j-1
FinTantque
Fin pour

Sortie
Afficher la liste X1, X2,....Xn


Les questions qui me sont poser a partir de l'algorithme sont :

a) Faire fonctionner cet algorithme : reproduire et completer le tableau suivant afin de suivre l'evolution des variables. On prend n=4 et la liste : 7361

i 1 1 ...
j 4 3 ...
Liste 7316 7136 ...

b)Appliquer l'algorithme a d'autres listes et indiquer le rôle de l'algorithme

Merci d'avance de vos reponses.

1

Réponses

Meilleure réponse !
2013-01-12T17:18:28+01:00

Soit X1 = 7136 ; X2 = 7316 ; X3 = 7613 ; X4 = 7361

I = 1???

J = 4      7361 < 7613 alors X1 = 7136 ; X2 = 7316 ; X3 = 7361 ; X4 = 7613

J = 3      7361 < 7316 non alors J = 2

J = 2      7316 < 7136  non alors J = 1

fin la série de nombres est triée

X1 = 7136 ; X2 = 7316 ; X3 = 7361 ; X4 = 7613

 

refais avec des nombres différents