Bonjours alors voilà je recherche actuellement de l'aide sur un DM d'algorithmie , sujet : Exercice 1 : On considère l'algorithme suivant : Entrée : Entrer x Traitement : A prend la valeur x-1 B prend la valeur 1/A C prend la valeur 2*B Sortie : Afficher C 1)Faire tourner cet algorithme avec x=0 puis x=2 2) Que se passe-t-il pour x=1 ? Pourquoi ? 3) Quel nombre doit-on entrer pour obtenir 1 en sortie de cet algorithme ? justifier. Exercice2: Un magasin de reprographie a élaboré l'algorithme ci-contre permettant de calculer automatiquement le calcul du prix P à payer pour N photocopies réalisées. Saisir un nombre positif N Si N≤ 20 Alors P reçoit 0.30*N Sinon Si N>50 Alors P reçoit 0.10*N Sinon P reçoit 0.15*N FinSi FinSi Afficher P Calculer le prix à payer pour 10 photocopies , 30 photocopies et 60 photocopies Voilà ou sinon mon msn [email protected] merci

1

Réponses

2012-12-23T12:32:31+01:00

c = 2/(x-1)

si x = 0 C = -2  ; si x = 2 C = 2

pour x = 1 il n'y ap as de solution pour C car il faudrait diviser par 0

pour C = 1 il faut x - 1 = 2 donc X = 3

 

tu peux faire un organigramme de l'algorithme. en horizontale le réponse au test est oui

 

N<=20? -----> P = 0,3.N  si N = 10 ---> P = 3

 |

N<= 50?-----> P = 0,15.N   si N = 30  ---> P = 4,5

  |

N > 50 ? -----> P = 0,1.N    si N = 60 ----> P = 6