Saisir n

K prend la valeur 0

A prend la valeur 0

F prend la valeur 0

Pour i variant de 1 à n

Affecter à A un nombre entier aléatoire entre 1 et 6

Si A=1

Affecter à K la valeur K+1

Fin si

Fin pour

Affecter à f la valeur K/n

Afficher f.

Quen fait cet algorithme ?

1

Réponses

  • Utilisateur Brainly
2014-03-16T14:31:53+01:00
Saisir n
n=5
K prend la valeur 0
K=0
A prend la valeur 0
A=0
F prend la valeur 0
F=0
Pour i variant de 1 à n   
Affecter à A un nombre entier aléatoire entre 1 et 6   
Si A=1      
Affecter à K la valeur K+1 
K =P(1) 
Fin si
Fin pour
Affecter à f la valeur K/n
f=f(1)
Afficher f

l'algorithme donne alors la fréquence d'apparition de la face "1" sur les n lancers