Besoin d'aide ! Urgent !
Coucou tout le monde ! quelqu'un pourrait m'aider ? s'il vous plaît ! Merci beaucoup d'avance !

1/ a.Proposer un algorithme donnant le signe de ax+b. Cet algorithme doit demander a et b puis afficher pour quelles valeurs de x, ax+b est positif.
b.Programmer cet algorithme sur une calculatrice.

2/
Soit f et g les fonctions définies par : f(x) = 0,64x + 0,512 et g(x) = - 1,53x + 52,02.
Dresser le tableau de signes de f et de g en utilisant l'algorithme précédent.

1

Réponses

2014-01-14T14:54:42+01:00
Ax+b=0 ssi x=-b/a (avec a non nul) la variation de ax+b dépend de a. Si a<0, ax+b décroit et croit dans le cas contraire.
L'algorithme doit donc faire ceci :
Demander a et b
Si a=0 alors x toujours du signe de b
Si a<0 alors x>0 si x<-b/a et x<0 si x>-b/a
Si a>0 alors x>0 si x>-b/a et x<0 si x<-b/a
VARIABLES
a EST_DU_TYPE NOMBRE
b EST_DU_TYPE NOMBRE
c EST_DU_TYPE NOMBRE
DEBUT_ALGORITHME
LIRE a
LIRE b
SI (a==0) ALORS
DEBUT_SI
SI (b>=0) ALORS
DEBUT_SI
AFFICHER "ax+b≥0 pour tout x"
FIN_SI
SINON
DEBUT_SINON
AFFICHER "ax+b<0 pour tout x"
FIN_SINON
FIN_SI
SINON
DEBUT_SINON
AFFICHER "ax+b≥0 pour tout x"
SI (a>0) ALORS
DEBUT_SI
AFFICHER "≥"
FIN_SI
SINON
DEBUT_SINON
AFFICHER "≤"
FIN_SINON
c PREND_LA_VALEUR -b/a
AFFICHER c
FIN_SINON
FIN_ALGORITHME
Cela vous semble-t-il juste ?