Bonjour, je ne sais pas comment répondre à cet exercice. Un client décide de louer un studio pour ses vacances au ski. Il peut choisir entre deux formules de location:Formule A : Prix fixe de 250€ + 10€ de charges par jour.
Formule B: Prix fixe de 300€ + 5 € de charges par jour.
1. Quelle est la formule la plus avantageuse pour une location d'une semaine ? de 12 jours ?
2. On appelle A(N)b(respectivement B(N)) le montant à régler en fonction du nombre N de jours de location pour la formule A (respectivement B). Exprimer ces deux fonctions A(N) et B(N).
3. Recopier et compléter ces deux algorithmes qui permettront au consommateur de connaître en fonction de N la formule la plus avantageuse. On appelle D la différence de prix entre formule B et formule A.

Initialisation
Variables: N,A,B
Lire: ....

Traitement des données
A prend la valeur : ...
B prend la valeur : ...
Sortie
Si...alors afficher "B"
Sinon
Si... alors afficher "A ou B"
Sinon afficher "A"
Fin Si
Fin Si
Fin

Initialisation
Variables: N,D
Lire: ....

Traitement des données
D rend la valeur ...
Sortie
Si...alors afficher "B"
Sinon
Si... alors afficher "A ou B"
Sinon afficher "A"
Fin Si
Fin Si
Fin
Quelqu'un pourrait-il me venir en aide, s'il vous plaît ?Merci pour vos réponses.

1

Réponses

Meilleure réponse !
2013-11-01T20:38:26+01:00
Coucou, je suis sûre pour les deux premières questions mais pas pour l'algorithme ^^"                                                                                                                                                      1. Quelle est la formule la plus avantageuse pour une location d'une semaine ? de 12 jours ?
Pour une semaine : FA : 250 + 10*7 = 320 / FB : 300 + 5*7 = 335 Pour un séjour d'une semaine, la formule A est avantageuse. Pour douze jours : FA : 250 + 10*12 = 370 / FB : 300 + 5*12 = 360 Pour un séjour de 12 jours la formule B est plus avantageuse.
2. On appelle A(N)b(respectivement B(N)) le montant à régler en fonction du nombre N de jours de location pour la formule A (respectivement B). Exprimer ces deux fonctions A(N) et B(N).

A(N) → 250 + 10x / B(N) → 300 + 5x                                                                                                                                                                                                                          Initialisation 
Variables: N,A,B
Lire: A; B; N

Traitement des données
A prend la valeur : 250 + 10x
B prend la valeur : 300 + 5x
Sortie
Si A > B alors afficher "B"
Sinon
Si A = B alors afficher "A ou B"
Sinon afficher "A" 
Fin Si 
Fin Si 
Fin 

Initialisation
Variables: N,D
Lire: N, D

Traitement des données
D rend la valeur B - A
Sortie
Si D > 0 alors afficher "B"
Sinon
Si D = 0 alors afficher "A ou B"
Sinon afficher "A"
Fin Si 
Fin Si 
Fin                                                                                                                                                                                  

Merci beaucoup! :D
Il vient d'où le 0 dans le 2e algorithme ? o: