26086

Bonjour,
Voici mon exercice de maths :
Partie A :
On considère la fonction g définie sur [1;+infini[ par g(x) = ln x - (1/2).

1) Etudier le sens de variation de g sur [1;+infini[.

2) Résoudre l'équation g(x) = 0 dans [1;+infini[.

3) En déduire que g(x) > 0 si, et seulement si, x > V(e).
Partie B :
On considère la fonction f définie sur [1;+infini[ par f(x) = 2x² (ln x - 1) + 2.

1) On appelle f' la fonction dérivée de la fonction f sur l'intervalle [1;+infini[.

a) Montrer que pour tout nombre réel x de l'intervalle [1;+infini[, f'(x) = 4x g(x).

b) Etudier le signe de f'(x) sur [1;+infini[ et en déduire le sens de variation de f sur [1;+infini[.
2) a) Montrer que, dans l'intervalle [2;3], l'équation f(x) = 0 admet une solution unique notée a.

b) Déterminer un encadrement d'amplitude 10-2 de a.

3) L'algorithme ci-contre permet de déterminer un encadrement de la solution a.

Entrées
Saisir a, b et p trois nombres réels tels que 2 ≤ a < b ≤ 3 et p > 0.
Traitement

Tant que f(a) * f(a + p) > 0 et a + p ≤ b, a prend la valeur a + p.

Fin Tantque

Sortie

Afficher "La solution est dans l'intervalle [a;a+p]"
a) Préciser le rôle des variables a, b et p.
b) Expliquer l'instruction "Tant que f(a) * f(a + p) > 0"

c) Appliquer l'algorithme avec a = 2, b = 3 et p = 0,1.

d) Quelles valeurs faudrait-il saisir pour a, b et p afin que l'algorithme retourne l'encadrement trouvé à la question précédente?

e) L'algorithme tel qu'il a été écrit suppose que la solution appartient à l'intervalle [a;b] saisi en entrée.
Modifier l'algorithme de sorte que s'il n'y a pas de solution dans cet intervalle, une phrase bien choisie soit retournée.
Voici ce que j'ai fait :

Partie A :

1) g(x) = ln(x) - (1/2) sur [1 ;+∞[

g’(x) = 1/x

1/x > 0 car si x appartient à [1 ;+∞[ alors x est toujours supérieur à 0 alors g’(x) est toujours supérieur à 0 alors g(x) est toujours croissante.

2) g(x) = 0

ln(x) – 1/2 = 0

ln(x) = 0,5

eln(x) = e0,5

x = e0,5

x = V(e)

3) g(x) > 0

ln(x) - 1/2 > 0

ln(x) > 0,5

eln(x) > e0,5

x > e0,5

x > V(e)

Partie B :

1) a) f(x) = 2x² (ln x – 1) + 2

f’(x) = 4x * (ln(x) – 1) + (1/x * 2x²)

f’(x) = 4x * (ln(x) – 1) + (2x²/x)

f’(x) = 4x * (ln(x) – 1) + 2x

f’(x) = 4x * ln(x) – 4x + 2x

f’(x) = 4x (ln(x) - 1/2)

b) f’(x) est négatif sur [1 ; V(e)] et positif sur [V(e) ;+∞[.

Donc f(x) est décroissante sur [1 ; ] et croissante sur [ ;+∞[.

2) a) L’équation f(x) = 0 n’admet qu’une solution sur [2 ;3] car elle est strictement croissante sur [2 ;3] et comme f(2) < 0 et f(3) > 0, il y a bien une seule et unique valeur sur cet intervalle en laquelle f(x) = 0.

b) 2,21 < a < 2,22

3) a) a, b et p permettent de trouver la valeur où f(x) = 0.

b) Cette instruction signifie que l’algorithme ne marchera que quand f(a) * f(a + p) > 0 et que quand f(a) * f(a + p) < 0, il se passera autre chose.

d) Il faudrait saisir a = 2,2, b = 2,3 et p = 10-2.

J'ai fait en plus l'algorithme sur algobox :

CODE DE L'ALGORITHME :

1 VARIABLES

2 a EST_DU_TYPE NOMBRE

3 b EST_DU_TYPE NOMBRE

4 p EST_DU_TYPE NOMBRE

5 DEBUT_ALGORITHME

6 AFFICHER "2 ≤ a < b ≤ 3 et p > 0"

7 TANT_QUE (a<2 ou a>=b ou b>3 ou p<=0) FAIRE

8 DEBUT_TANT_QUE

9 LIRE a

10 LIRE b

11 LIRE p

12 FIN_TANT_QUE

13 SI (F1(a)*F1(b)<0) ALORS

14 DEBUT_SI
15 TANT_QUE (F1(a)*F1(a+p)>0 ET a+p<=b) FAIRE

16 DEBUT_TANT_QUE
17 a PREND_LA_VALEUR a+p

18 FIN_TANT_QUE

19 AFFICHER "La solution est dans l'intervalle ["

20 AFFICHER a

21 AFFICHER " ; "

22 a PREND_LA_VALEUR a+p

23 AFFICHER a

24 FIN_SI

25 SINON

26 DEBUT_SINON

27 AFFICHER "Il n'y a pas de solution dans l'intervalle ["
28 AFFICHER a

29 AFFICHER " ; "

30 AFFICHER b

31 FIN_SINON
32 AFFICHER "]"

33 FIN_ALGORITHME

34

35 Fonction numérique utilisée :

36 F1(x)=2*pow(x,2)*(log(x)-1)+2

Est-ce que quelqu'un pourra me vérifier s'il vous plaît car à mon avis, il y a quelques fautes?

1

Réponses

Meilleure réponse !
2013-05-02T17:58:15+02:00

pour 1 et 2 , parfait

pour 3 tu aurais pu dire que puisque g croissante et vaut 0 en Ve elle est positive après.

Partie B

Donc f(x) est décroissante sur [1 ;Ve ] et croissante sur [ Ve ;+∞[.

 

ça me semble bon mais je ne peux pas te conseiller pour le programme.

je n'ai pas vu d'erreur mais je ne suis pas familioer de ce langage.

 

Je trouve ta démarche aussi intéressante qu'intelligente, je t'en félicite et te conseille de continuer.