Bonjour pouvais vous m'aider s'il vous plaît j'ai un algorithme et je ne le comprend pas voilà l'algorithme: VARIABLES x est du type nombre y est du type nombre DÉBUT Algorithme lire x SI (x!=3) ALORS DÉBUT SI y prend la valeur (2*x-1)/(x-3) AFFICHER "f(" AFFICHER x AFFICHER ")=" AFFICHER y FIN SI Sinon DÉBUT SINON afficher " FIN SINON FIN ALGORITHME Voici les questions: a- Expliquez la signification de l'écriture (x!= 3) b-Expliquez la fonction de cette algorithme , puis le compléter sur le sujet si quelqu'un veut bien m'aider s'il vous plaît merci :)

1

Réponses

  • Utilisateur Brainly
2013-05-01T09:06:00+02:00

algorithme:

VARIABLES x est du type nombre y est du type nombre

DÉBUT Algorithme

lire x

SI (x≠3) ALORS

DÉBUT

SI y prend la valeur (2*x-1)/(x-3)

AFFICHER "f("

AFFICHER x AFFICHER ")="

AFFICHER y

FIN SI

Sinon

DÉBUT

SINON

afficher "valeur interdire !"

FIN SINON

FIN ALGORITHME

 

Voici les questions:

 

a- Expliquez la signification de l'écriture (x!= 3)

(x!= 3) signifie en fait que x est différent de 3

(j'ai corrigé l'algorithme...)

 

b-Expliquez la fonction de cette algorithme

cet algorithme explique que :

* si x est différent de 3 alors il renvoie y=f(x)=(2x-1)/(x-3) image de x par f

* si x=3 alors il renvoie le message "valeur interdite !"