Bonjour j'ai vraiment besoin de votre aide s'il vous plait ...

On lance un dé équilibré, si le 6 sort le lièvre a gagné, sinon la tortue avance d'une case. La tortue gagne si elle réussit à avancer de 6 cases.

Voila un algorithme simulant une partie, et affichant "L" si le lièvre gagne et "T" si la tortue gagne.

Traitement
x prend la valeur d'un nombre aléatoire entre 1 et 6
t prend la valeur 0
Tant que x différent de 6 et t différent de 6
t prend la valeur t + 1
x prend la valeur d'un nombre aléatoire compris entre
1 et 6
Fin tant que
si x=6, alors afficher "L", sinon afficher "T"
Fin si

Je doit traduire cet algorithme en langage TI mais je ne sais pas comment on fait.
Ensuite je doit le modifier pour simuler non pas une partie mais "n" parties.

Je n'y arrive vraiment pas, est ce que quelqu'un pourrait m'aider ?

1

Réponses

2013-04-30T16:09:08+02:00

alors j'e peux pas verfier mais :

 

entAléat(1,6)->A

T->0

If a=6

Disp F

Then

Disp L

 

J'ai pas compris : Tant que x différent de 6  et t différent de 6
        t prend la valeur t + 1

Tu devrait t'inspirer du mien pour rajouter dedans cet contrainte