Bonjour, j'ai besoin d'aide pour un exercice de maths de 2nde, ça fait des jours que je reste bloquée dessus ..:

"On considère l'algorithme suivant :

Variables : ...

Entrée : Saisir N (entier naturel non nul)

Initialisation : S prend la valeur 0

Traitement : Pour I variant de 1 jusqu'à N, faire

Saisir A

S prend la valeur S+A

Fin pour

M prend la valeur S/N

Sortie : Afficher M

Questions:

1) quelles sont les différentes variables utilisées (ça j'ai trouvé) et précisez si elles sont entières ou réelles ainsi que ce qu'elles représentent (ça je comprends pas). 2) faire "tourner" l'algorithme en entrant des valeurs de votre choix et en précisant le contenu des variables au fur et à mesure de l’exécution. (ça je sais pas je l'ai jamais fais) 3) que permet cet algorithme ? (????)

Et pour la dernière question ça devrait aller.

Si quelqu'un peut m'aider ce serait vraiment très gentil.

1

Réponses

Meilleure réponse !
  • Utilisateur Brainly
2013-04-27T15:55:35+02:00

algorithme :

Variables : N est un nombre entier

                    S est un nombre réel

                    M est un nombre réel

                    A est un nombre réel

Entrée : Saisir N (entier naturel non nul)

Initialisation : S prend la valeur 0

Traitement : Pour I variant de 1 jusqu'à N, faire

                        Saisir A

                       S prend la valeur S+A

                      Fin pour

                      M prend la valeur S/N

Sortie : Afficher M

 

Questions:

1) quelles sont les différentes variables utilisées (ça j'ai trouvé) et précisez si elles sont entières ou réelles ainsi que ce qu'elles représentent

N est un nombre entier

S est un nombre réel

M est un nombre réel

A est un nombre réel

 

2) faire "tourner" l'algorithme en entrant des valeurs de votre choix et en précisant le contenu des variables au fur et à mesure de l’exécution.

si N=2 et A=5 alors

N=1 ; S=0 ; A=5 ; S=5 ;

N=2 ; S=10

M=5

 

si N=3 et A=4 alors

N=1 ; S=0 ; A=4 ; S=4 ;

N=2 ; S=8

N=3 ; S=12

M=4

 

3) que permet cet algorithme ?

ct algorithme renvoie la valeur de A initiale