Bonsoir je suis bloqué, j'ai du mal avec l'algobox.. si quelqu'un peux m'aider svp!

Sujet :

La société TEXIO vend des calculatrices.
Le nombre de calculatrices fabriquées chaque mois varie entre 0
et 40 000.
Le coût de fabrication dépend du nombre de calculatrices
fabriquées.
Soit x, le nombre de calculatrices fabriquées en un mois (exprimé
en milliers).
On note f(x) le coût de fabrication d’une calculatrice (exprimés
en euros) de ces calculatrices.
L’algorithme ci-contre permet à partir de x de calculer la valeur
de f(x).

1 VARIABLES
2 x EST_DU_TYPE NOMBRE
3 y EST_DU_TYPE NOMBRE
4 DEBUT_ALGORITHME
5 LIRE x
6 SI (x>=30 ET x<=40) ALORS
7 DEBUT_SI
8 y PREND_LA_VALEUR 34-0.1*x
9 FIN_SI
10 SI (x>=10 ET x<30) ALORS
11 DEBUT_SI
12 y PREND_LA_VALEUR 1.2*x-5
13 FIN_SI
14 SI (x>=0 ET x<10) ALORS
15 DEBUT_SI
16 y PREND_LA_VALEUR -x+17
17 FIN_SI
18 AFFICHER "C(x)="
19 AFFICHER y
20 FIN_ALGORITHME

Question:

Modifier l’algorithme pour qu’il affiche le coût total (à la place du coût unitaire par
calculatrice).

1

Réponses

2013-01-25T21:31:08+01:00

y=f(x) est le cout d'une calculatrice dans l'ago de départ.

 

Dans le nouveau algo, ajouter z est le cout total.

 

1 VARIABLES

2 x EST_DU_TYPE NOMBRE

3 y EST_DU_TYPE NOMBRE

4 z EST_DU_TYPE NOMBRE

5 DEBUT_ALGORITHME

6 LIRE x

7 SI (x>=30 ET x<=40) ALORS

8 DEBUT_SI

9 y PREND_LA_VALEUR 34-0.1*x

10 FIN_SI

11 SI (x>=10 ET x<30) ALORS

12 DEBUT_SI

13 y PREND_LA_VALEUR 1.2*x-5

14 FIN_SI

15 SI (x>=0 ET x<10) ALORS

16 DEBUT_SI

17 y PREND_LA_VALEUR -x+17

18 FIN_SI

19 z PREND_LA_VALEUR y*x

20 AFFICHER "C(x)="

21 AFFICHER z

22 FIN_ALGORITHME