Réponses

2014-05-22T00:03:15+02:00
Bonsoir,

1) Arbre en pièce jointe.

2) Les abscisses finales possibles de la puce sont : -4 , -2 , 0 , 2 , 4.

3) Probabilité que l'abscisse finale soit égale à -2 :
Il y a 4 cas favorables parmi les 16 cas possibles.
p(x=-2)=\dfrac{4}{16}=\dfrac{1}{4}

4) X représente l'abscisse de la puce.
N est une valeur imaginant le saut au choix.
Cette valeur peut être 0 ou 1.
Si N = 0, alors la puce recule d'un pas.
Dans ce cas, l'abscisse est diminuée de 1 unité.
Sinon, si N = 1, alors la puce avance d'un pas.
Dans ce cas, l'abscisse est augmentée de 1 unité.
La dernière ligne affiche l'abscisse x de la puce.

5) X prend la valeur 0
    Pour K allant de 1 à 4
           N prend la valeur aléatoire 0 ou 1
           Si N=0, alors X prend la valeur X-1
           sinon X prend la valeur X+1
           Fin Si
    Fin Pour 
    Afficher la valeur de X.

6) Programme Algobox en pièce jointe.
Le voici en mode texte :
1   VARIABLES
2     X EST_DU_TYPE NOMBRE
3     N EST_DU_TYPE NOMBRE
4     K EST_DU_TYPE NOMBRE
5   DEBUT_ALGORITHME
6     X PREND_LA_VALEUR 0
7     POUR K ALLANT_DE 1 A 4
8       DEBUT_POUR
9       N PREND_LA_VALEUR ALGOBOX_ALEA_ENT(0,1)
10      SI (N==0) ALORS
11        DEBUT_SI
12        X PREND_LA_VALEUR X-1
13        FIN_SI
14        SINON
15          DEBUT_SINON
16          X PREND_LA_VALEUR X+1
17          FIN_SINON
18      FIN_POUR
19    AFFICHER X
20  FIN_ALGORITHME