a) Dans un repère , placer les points: A(1;5) B(-1;-1) C(2;8). b) On applique l'algorithme ci-dessous aux points A,B,C ; Calculer les produits P et Q. Entrées: Saisir xA,yA,xB,yB,xC,yC. : coordonnées de trois points A,B et C. Initialisations : P prend la valeur (yB -yA) * (xC-xA) Q prend la valeur (yC-yA)*(xB-xA) c) Reprendre les questions a) et b) avec les points : A(1;5, B(-1;-1) et C (3;9). d) Compléter le test ci-dessous. Sorties: Si P=Q alors ....... sinon .... FinSi e) Quel est le rôle de cet algorithme ? Justifier. f) Ecrire un programme mettant en oeuvre l'algorithme.

1

Réponses

  • Utilisateur Brainly
2012-05-03T10:52:55+02:00

*****************************************

1 VARIABLES
2 XA EST_DU_TYPE NOMBRE
3 YA EST_DU_TYPE NOMBRE
4 XB EST_DU_TYPE NOMBRE
5 YB EST_DU_TYPE NOMBRE
6 XC EST_DU_TYPE NOMBRE
7 YC EST_DU_TYPE NOMBRE
8 P EST_DU_TYPE NOMBRE
9 Q EST_DU_TYPE NOMBRE
10 DEBUT_ALGORITHME
11 LIRE XA
12 LIRE YA
13 LIRE XB
14 LIRE YB
15 LIRE XC
16 LIRE YC
17 P PREND_LA_VALEUR (YB-YA)*(XC-XA)
18 Q PREND_LA_VALEUR (YC-YA)*(XB-XA)
19 SI (P==Q) ALORS
20 DEBUT_SI
21 AFFICHER "les oints A,B et C sont alignés"
22 FIN_SI
23 SINON
24 DEBUT_SINON