Bonjour, je ne sais pas comment répondre à cet exercice. Un client décide de louer un studio pour ses vacances au ski. Il peut choisir entre deux formules de location:Formule A : Prix fixe de 250€ + 10€ de charges par jour.
Formule B: Prix fixe de 300€ + 5 € de charges par jour.
1. Quelle est la formule la plus avantageuse pour une location d'une semaine ? de 12 jours ?
2. On appelle A(N)b(respectivement B(N)) le montant à régler en fonction du nombre N de jours de location pour la formule A (respectivement B). Exprimer ces deux fonctions A(N) et B(N).
3. Recopier et compléter ces deux algorithmes qui permettront au consommateur de connaître en fonction de N la formule la plus avantageuse. On appelle D la différence de prix entre formule B et formule A.

Initialisation
Variables: N,A,B
Lire: ....

Traitement des données
A prend la valeur : ...
B prend la valeur : ...
Sortie
Si...alors afficher "B"
Sinon
Si... alors afficher "A ou B"
Sinon afficher "A"
Fin Si
Fin Si
Fin

Initialisation
Variables: N,D
Lire: ....

Traitement des données
D rend la valeur ...
Sortie
Si...alors afficher "B"
Sinon
Si... alors afficher "A ou B"
Sinon afficher "A"
Fin Si
Fin Si
Fin
Quelqu'un pourrait-il me venir en aide, s'il vous plaît ?Merci pour vos réponses.

1

Réponses

2013-11-01T18:10:57+01:00
Salut, tu es en quelle classe ?
Je ne sais pas si cela peut t'interressait, mais je peux t'aider pour la premires question ?
En 2nde. C'est la 2eme et 3 eme questions que je n'y arrive pas :/
Tu as réussie la première ? J'ai essayer mais je n'y arrive pas désolé. Je suis en seconde, et je n'ai pas fait ça l'année dernière.
Oui, je l'ai fait x). Merci quand même éè.
Hih! De rien